This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen
Bug 957 - Error when compiling with icl 15.0
Summary: Error when compiling with icl 15.0
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Sparse (show other bugs)
Version: 3.2
Hardware: x86 - 64-bit Windows
: Normal Compilation Problem
Assignee: Nobody
URL:
Whiteboard:
Keywords:
: 964 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-02-17 12:39 UTC by Marcho
Modified: 2019-12-04 14:15 UTC (History)
3 users (show)



Attachments

Description Marcho 2015-02-17 12:39:02 UTC
The easiest way to reproduce is to try and build the sparse_extra_1 test.

Cmake 3.1 generated VS11 solution.

Results:

1>------ Build started: Project: ZERO_CHECK (Intel C++ 15.0), Configuration: Debug x64 ------
2>------ Build started: Project: sparse_extra_1 (Intel C++ 15.0), Configuration: Debug x64 ------
2>  sparse_extra.cpp
2>C:\Users\marcho\RTC\Eigen\eigen\Eigen/src/SparseCore/SparseBlock.h(358): error : no instance of overloaded function "Eigen::SparseMatrixBase<Derived>::innerVectors" matches the specified type
2>    Block<Derived,Dynamic,Dynamic,true> SparseMatrixBase<Derived>::innerVectors(Index outerStart, Index outerSize)
2>                                                                   ^
2>  
2>C:\Users\marcho\RTC\Eigen\eigen\Eigen/src/SparseCore/SparseBlock.h(370): error : no instance of overloaded function "Eigen::SparseMatrixBase<Derived>::innerVectors" matches the specified type
2>    const Block<const Derived,Dynamic,Dynamic,true> SparseMatrixBase<Derived>::innerVectors(Index outerStart, Index outerSize) const
2>                                                                               ^
2>  
2>  compilation aborted for C:\Users\marcho\RTC\Eigen\eigen\unsupported\test\sparse_extra.cpp (code 2)
========== Build: 1 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
Comment 1 Gael Guennebaud 2015-02-18 11:35:28 UTC
This should do the job:

Devel: https://bitbucket.org/eigen/eigen/commits/9022880b3740/
3.2: https://bitbucket.org/eigen/eigen/commits/96f1c993b94d/
Comment 2 Gael Guennebaud 2015-02-19 12:15:32 UTC
*** Bug 964 has been marked as a duplicate of this bug. ***
Comment 3 Nobody 2019-12-04 14:15:06 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/957.

Note You need to log in before you can comment on or make changes to this bug.