This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen
Bug 744 - The umeyama_5 test fails for seed 1392390306
Summary: The umeyama_5 test fails for seed 1392390306
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Geometry (show other bugs)
Version: 3.2
Hardware: All All
: Normal Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-14 19:10 UTC by Benoit Steiner
Modified: 2019-12-04 13:00 UTC (History)
4 users (show)



Attachments

Description Benoit Steiner 2014-02-14 19:10:01 UTC
I compiled the latest version of the Eigen codebase for x64 with SSE3 enabled. ./umeyama_5 s1392390306 fails as follow:
Initializing random number generator with seed 1392390306
Repeating each test 10 times
Test (run_fixed_size_test<float, 4>(num_elements)) failed in /usr/local/google/home/bsteiner/EigenLatest/eigen/test/umeyama.cpp (154)
    error < Scalar(10)*std::numeric_limits<Scalar>::epsilon()
Stack:
  - (run_fixed_size_test<float, 4>(num_elements))
  - umeyama
  - Seed: 1392390306

Aborted (core dumped)
Comment 1 Hauke Heibel 2014-02-16 19:55:21 UTC
I just tried this on Visual Studio 2013 and cannot reproduce the issue. Which compiler did you use?
Comment 2 Benoit Steiner 2014-02-17 02:23:37 UTC
I used gcc4.8 running on Ubuntu.
Comment 3 Christoph Hertzberg 2014-02-17 09:42:10 UTC
I can confirm this on Ubuntu with gcc4.6.3. Moreover, with 10000 repetitions it fails almost every time -- with 1000 repetitions ca 1 out of 5 times.
I assume these are merely false negatives and we should just slightly reduce the precision (maybe 16*eps instead of 10*eps).
Comment 4 Christoph Hertzberg 2014-02-17 13:55:10 UTC
Another problem was that the problem got ill-posed if the scaling factor was very small compared to the translation part.
I relaxed the test-case here:
https://bitbucket.org/eigen/eigen/commits/50e33ba
https://bitbucket.org/eigen/eigen/commits/3e5302f
Comment 5 Nobody 2019-12-04 13:00:54 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/744.

Note You need to log in before you can comment on or make changes to this bug.