Just like we have Ones and Zero matrices, we could have NaN and Inf shortcuts. NaN is complementary to the EIGEN_INITIALIZE_MATRICES_BY_NAN option, and use cases of Inf are pretty obvious.
Regarding names, matlab has NaN(,) and Inf(,) functions, but we could go for more explicit names. In particular shouldn't we add plural "s" -> NaNs() and Infs() or Infinities()?
-- GitLab Migration Automatic Message --
This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.
You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/586.