I propose to insert in the file
after #define sign(x) is not anymore needed. This #define sign(x)
may conflict with a user definition of a sign(x) as it did in my
Maybe line 618 (after #undef EIGEN_AUTODIFF_DECLARE_GLOBAL_UNARY)
would be a good place?
(In reply to comment #0)
I actually don't see why this requires a #define at all. Either an inline function could be used or, as it is used only once, it could be expanded directly.
If for some technical reasons there must be a define then call it something like EIGEN_AUTODIFF_SIGN.
I've no clue how this stupid macro got there.
date: 2013-03-07 23:35:26
summary: Fix bug 561: remove useless sign macro
-- GitLab Migration Automatic Message --
This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.
You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/561.