In Constants.h there is a definition "const int Infinity = -1;"
This is a very bad name, because it is easily confused with an constant for an actual infinity (i.e. INFINITY); and doesn't reflect the fact that it means the infinity norm.
You should use something like InfinityNorm.
(This becomes especially annoying if you use Qt Creator which autocompletes "INF" to "Infinity")
We cannot change that name since that would break the API. Perhaps this could be considered for Eigen 4 in a very far future...
We can however introduce a new constant with the same value; and possibly mark the existing one as deprecated.