This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen
Bug 1681 - Optionally, use SVML functions if available.
Summary: Optionally, use SVML functions if available.
Status: RESOLVED DUPLICATE of bug 1259
Alias: None
Product: Eigen
Classification: Unclassified
Component: Core - vectorization (show other bugs)
Version: 3.4 (development)
Hardware: All All
: Low Feature Request
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-15 08:35 UTC by Christoph Hertzberg
Modified: 2019-12-04 18:30 UTC (History)
4 users (show)



Attachments

Description Christoph Hertzberg 2019-02-15 08:35:40 UTC
This came up in Bug 1678. 

We may optionally replace our own vector math functions and replace them by SVML, or some alternative:
https://stackoverflow.com/questions/31978592/

Pro:
 * We get immediate support for other functions like asin, erf, ...
 * Binary sizes would slightly reduce for people who use SVML anyway.
  
Maybe Contra: We could get worse performance (someone needs to check)
Comment 1 Gael Guennebaud 2019-02-15 10:44:44 UTC
Isn't it a duplicate of bug 1259 ?
Comment 2 Christoph Hertzberg 2019-02-15 12:47:30 UTC
Sorry, I seem to have missed that.

*** This bug has been marked as a duplicate of bug 1259 ***
Comment 3 Nobody 2019-12-04 18:30:23 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/1681.

Note You need to log in before you can comment on or make changes to this bug.