This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen
Bug 1336 - Doxygen page for Matrix doesn't show functions of MatrixBase that are documented outside the class definition
Summary: Doxygen page for Matrix doesn't show functions of MatrixBase that are documen...
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 3.3 (current stable)
Hardware: All All
: Normal Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-28 15:54 UTC by Zsbán Ambrus
Modified: 2019-12-04 16:28 UTC (History)
4 users (show)



Attachments

Description Zsbán Ambrus 2016-10-28 15:54:46 UTC
In the doxygen documentation for the Matrix class "http://eigen.tuxfamily.org/dox-devel/classEigen_1_1Matrix.html", the member functions that are both inherited from MatrixBase and are not from the Core module are not shown.  These member functions include eg.: cross, homogeneous, hnormalized, determinant, inverse, householderQr.  

This bug is still present in the online docs for the 3.3 branch.

The documentation for the MatrixBase class "http://eigen.tuxfamily.org/dox-devel/classEigen_1_1MatrixBase.html" does show these functions.
Comment 1 Gael Guennebaud 2016-10-29 13:52:46 UTC
Actually, it only shows methods that are documented in the class definition. All other methods are ignored: norm, normalized, adjoint, selfadjointView, etc.
Comment 2 Zsbán Ambrus 2017-01-04 13:47:00 UTC
I'm not sure if this is the same bug, but the doc page for MatrixBase "http://eigen.tuxfamily.org/dox-devel/classEigen_1_1MatrixBase.html" doesn't show the cwiseProduct member function.
Comment 3 Gael Guennebaud 2017-01-04 16:25:34 UTC
yes, same issue.
Comment 4 Gael Guennebaud 2017-01-04 17:23:27 UTC
actually, not, the issue is different here, and easier to workaround:

https://bitbucket.org/eigen/eigen/commits/70009b588a05/
Summary:     Bug 1336: fix doxygen issue regarding EIGEN_CWISE_BINARY_RETURN_TYPE
Comment 5 Gael Guennebaud 2017-01-04 21:04:58 UTC
I finally found a workaround:

https://bitbucket.org/eigen/eigen/commits/528638bce494/
Summary:     Bug 1336: workaround doxygen failing to include numerous members of MatriBase in Matrix

it easy, but it took me a while to end up with this nonsense...
Comment 6 Nobody 2019-12-04 16:28:40 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/1336.

Note You need to log in before you can comment on or make changes to this bug.