This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen
Bug 1083 - Allow IO for fixed size eigen types as Scalar type
Summary: Allow IO for fixed size eigen types as Scalar type
Status: RESOLVED DUPLICATE of bug 34
Alias: None
Product: Eigen
Classification: Unclassified
Component: General (show other bugs)
Version: 3.3 (current stable)
Hardware: All All
: Normal Feature Request
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-09 22:22 UTC by Gabriel Nützi
Modified: 2019-12-04 15:01 UTC (History)
3 users (show)



Attachments
patch for IO.h (2.93 KB, patch)
2015-10-09 22:22 UTC, Gabriel Nützi
no flags Details | Diff

Description Gabriel Nützi 2015-10-09 22:22:25 UTC
Created attachment 610 [details]
patch for IO.h

sfinae recursion to allow output of these...                                                        
 
Array<Matrix2d<double,2,1>, Dynamic, Dynamic > a;
Array<Matrix2d<double,2,1>, Dynamic, Dynamic > b;                  

std::cout << a*b << a << b;



( have needed a meta function   has_type<...>  for SFINAE?
is something already around in Eigen? did not find something )
Comment 1 Gael Guennebaud 2015-10-12 11:35:00 UTC
The problem is more general (see bug 34), and a better fix would thus be to specialize internal::significant_decimals_default_impl.

*** This bug has been marked as a duplicate of bug 34 ***
Comment 2 Gael Guennebaud 2015-10-12 13:20:47 UTC
For the record, I've added a more general patch there http://eigen.tuxfamily.org/bz/show_bug.cgi?id=34#c2
Comment 3 Nobody 2019-12-04 15:01:32 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/1083.

Note You need to log in before you can comment on or make changes to this bug.