This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen

Bug 828

Summary: Confusing documentation of many SparseMatrixBase methods
Product: Eigen Reporter: Christoph Hertzberg <chtz>
Component: SparseAssignee: Nobody <eigen.nobody>
Status: RESOLVED FIXED    
Severity: Documentation CC: chtz, gael.guennebaud, krishkanth.92
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Bug Depends on:    
Bug Blocks: 558    

Description Christoph Hertzberg 2014-06-23 23:35:06 UTC
The documentation of many SparseMatrixBase functions is shared with the corresponding dense functions -- including the code samples. That leads to some open questions, e.g., are block-expressions overwritable and are unaryExpressions called only for non-zeros?
Comment 1 Gael Guennebaud 2016-02-03 14:05:36 UTC
*** Bug 1163 has been marked as a duplicate of this bug. ***
Comment 2 Gael Guennebaud 2016-02-03 15:27:51 UTC
That's indeed an issue that has to be fixed asap. At last I clarified the manual pages for block-expressions:

https://bitbucket.org/eigen/eigen/commits/435cc19842f5/
Summary:     Clarify documentation on the restrictions of writable sparse block expressions.
Comment 3 Gael Guennebaud 2016-09-16 08:43:08 UTC
https://bitbucket.org/eigen/eigen/commits/8246548665f6/
Summary:     Bug 828: clarify documentation of SparseMatrixBase's unary methods.
Comment 4 Gael Guennebaud 2016-09-16 09:29:31 UTC
For blocks: https://bitbucket.org/eigen/eigen/commits/d065e32c45f6/


Should be good enough.
Comment 5 Nobody 2019-12-04 13:25:39 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/828.