This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen

Bug 606

Summary: Documentation compilation on RedHat
Product: Eigen Reporter: Albert <aaahaaah>
Component: DocumentationAssignee: Nobody <eigen.nobody>
Status: RESOLVED FIXED    
Severity: Unknown CC: gael.guennebaud, jacob.benoit.1, jitseniesen
Priority: Normal    
Version: 3.1   
Hardware: x86 - 64-bit   
OS: Linux   
Whiteboard:
Bug Depends on:    
Bug Blocks: 387    

Description Albert 2013-05-30 14:07:29 UTC
Hi All, I got the message below while compiling documentation (make doc).
Something missed in TeX installation, but it is not clear what.
My system: RedHat 6.4/64-bit

..........
Generating docs for compound Eigen::SplineTraits< Spline< _Scalar, _Dim, _Degree >, _DerivativeOrder >...
Generating docs for compound Eigen::SplineTraits< Spline< _Scalar, _Dim, _Degree >, Dynamic >...
Generating docs for compound Eigen::StdMapTraits...
Generating docs for compound Eigen::StdStemFunctions...
Generating namespace member index...
Generating file index...
Generating example index...
Generating file member index...
Generating bitmaps for formulas in HTML...
CMake Error: cmake version 2.6-patch 4
Usage: /usr/bin/cmake -E [command] [arguments ...]
Available commands: 
  chdir dir cmd [args]...   - run command in a given directory
  copy file destination     - copy file to destination (either file or directory)
  copy_if_different in-file out-file  - copy file if input has changed
  copy_directory source destination   - copy directory 'source' content to directory 'destination'
  compare_files file1 file2 - check if file1 is same as file2
  echo [string]...          - displays arguments as text
  echo_append [string]...   - displays arguments as text but no new line
  environment               - display the current enviroment
  make_directory dir        - create a directory
  md5sum file1 [...]        - compute md5sum of files
  remove_directory dir      - remove a directory and its contents
  remove [-f] file1 file2 ... - remove the file(s), use -f to force it
  tar [cxt][vfz] file.tar file/dir1 file/dir2 ... - create a tar archive
  time command [args] ...   - run command and return elapsed time
  touch file                - touch a file.
  touch_nocreate file       - touch a file but do not create it.
  create_symlink old new    - create a symbolic link new -> old

make[3]: *** [doc/CMakeFiles/doc] Error 1
make[2]: *** [doc/CMakeFiles/doc.dir/all] Error 2
make[1]: *** [doc/CMakeFiles/doc.dir/rule] Error 2
make: *** [doc] Error 2
Comment 1 Gael Guennebaud 2013-06-10 00:11:29 UTC
I think the problem is that  we specify:

cmake_minimum_required(VERSION 2.6.2)

while we likely require a more recent cmake version, like 2.8.x
Comment 2 Jitse Niesen 2013-06-17 23:18:43 UTC
Specifically, we use "cmake -E rename" in the doc file which is not present in cmake 2.6.4 (I had to install that version to find this out). As far as I can make out, it was added in cmake 2.8.0. Additionally, FindFFTW uses the QUIET keyword in the pkgconfig macro, which was introduced in cmake 2.8.2. Hence, I specified that we need at least that version (not sure that it suffices though). 

changeset:   5352:355f818042a4
summary:     Require at least cmake version 2.8.2 (bug 606).
Comment 3 Gael Guennebaud 2013-06-18 00:50:10 UTC
Thanks a lot for finding the right version. Works for me after compiling cmake 2.8.2, so let's close it.
Comment 4 Nobody 2019-12-04 12:20:52 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/606.