This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen

Bug 346

Summary: 2 pages with unsupported modules, only 1 fully functional
Product: Eigen Reporter: edx <eu>
Component: DocumentationAssignee: Nobody <eigen.nobody>
Status: NEW ---    
Severity: minor CC: gael.guennebaud, jacob.benoit.1, jitseniesen
Priority: ---    
Version: 3.0   
Hardware: All   
OS: All   
Whiteboard:

Description edx 2011-09-08 13:28:08 UTC
In the generated documentation (both online and local latest hg), there are 2 pages with "Unsupported modules":

1. http://eigen.tuxfamily.org/dox-devel/unsupported/group__Unsupported__modules.html which has good links to individual modules (e.g. http://eigen.tuxfamily.org/dox-devel/unsupported/group__NonLinearOptimization__Module.html)

2. http://eigen.tuxfamily.org/dox-devel/group__Unsupported__modules.html which has links to individual modules, which are themselves empty (e.g. http://eigen.tuxfamily.org/dox-devel/group__NonLinearOptimization__Module.html)

[ I already replaced (2.) by (1.) at the main wiki page. ]
Comment 1 Jitse Niesen 2011-09-08 14:02:09 UTC
Page (2.) should no longer be generated. At least that's the case on my computer. You are right that page (2.) is still present online, but that is an old version; have a look at the bottom where it says when the file is generated, and you'll see that page (2.) has a date of 6 September while all other pages, including page (1.), have a date of 8 September (as I'm writing this). 

Apparently, the old html pages are not deleted when the documentation is generated. Perhaps somebody with access to the server can delete (1.)? But I guess it is not that much of a problem as long as there are no links to it.

Thanks for changing the link on the main page on the wiki; I forgot about that. I found another link which I changed.
Comment 2 Jitse Niesen 2011-11-14 14:58:25 UTC
Ideally, on http://eigen.tuxfamily.org/dox-devel/modules.html the unsupported modules like ADOLC are showed under the item 'Unsupported modules'. I think this is a doxygen bug. I filed a report at https://bugzilla.gnome.org/show_bug.cgi?id=658430 .
Comment 3 Nobody 2019-12-04 11:06:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/346.