This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen

Bug 1651

Summary: EIGEN_GEBGP_ONESTEP: inconsistent operand constraints in an ‘asm’
Product: Eigen Reporter: Matthew Woehlke <matthew.woehlke>
Component: Core - vectorizationAssignee: Nobody <eigen.nobody>
Status: RESOLVED DUPLICATE    
Severity: Compilation Problem CC: chtz, gael.guennebaud, jacob.benoit.1, markos, matthew.woehlke
Priority: Normal    
Version: 3.3 (current stable)   
Hardware: All   
OS: All   
Whiteboard:

Description Matthew Woehlke 2018-12-25 19:31:11 UTC
While trying to compile some code¹ that uses Eigen, I am receiving the following build error(s):

   /usr/include/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1226:13:
   error: inconsistent operand constraints in an ‘asm’
             EIGEN_GEBGP_ONESTEP(0);
   (...several more of the same macro with different argument on subsequent lines...)

It seems I am not the only one:
  https://github.com/tensorflow/tensorflow/issues/24457https://github.com/kitware/kwiver — in arrows/core/triangulate.cxx)

This appears to have started happening "recently", though it's been a while since I did a clean build of my code, so it's hard to say exactly when it started. Given the CentOS report, it seems plausible this is a compiler problem rather than an issue in Eigen itself?
Comment 1 Matthew Woehlke 2018-12-25 19:34:25 UTC
Note: downgrading from eigen3-devel-3.3.6-1.fc29.noarch to eigen3-devel-3.3.5-2.fc29.noarch seems to have "fixed" the problem.
Comment 2 Christoph Hertzberg 2018-12-25 19:54:25 UTC
Should be fixed in 3.3.7 as well

*** This bug has been marked as a duplicate of bug 1643 ***
Comment 3 Nobody 2019-12-04 18:18:57 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/1651.