This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen

Bug 1643

Summary: Compilation failure
Product: Eigen Reporter: Darcy <darcy>
Component: Core - generalAssignee: Nobody <eigen.nobody>
Status: RESOLVED FIXED    
Severity: Unknown CC: chtz, darcy, gael.guennebaud, jacob.benoit.1, matthew.woehlke
Priority: Normal    
Version: 3.3 (current stable)   
Hardware: All   
OS: All   
Whiteboard:
Bug Depends on:    
Bug Blocks: 814    

Description Darcy 2018-12-11 08:30:48 UTC
Using Eigen at commit 71546f1 causes compilation error in debug mode.

OS: Fedora 29
Compiler: gcc 8.2.1
Compilation options: cmake -DCMAKE_BUILD_TYPE=Debug

I only get this with debug on, in release mode it's all sunny skies.

Error message:

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h: In member function 'void Eigen::internal::gebp_kernel<LhsScalar, RhsScalar, Index, DataMapper, mr, nr, ConjugateLhs, ConjugateRhs>::operator()(const DataMapper&, const LhsScalar*, const RhsScalar*, Index, Index, Index, Eigen::internal::gebp_kernel<LhsScalar, RhsScalar, Index, DataMapper, mr, nr, ConjugateLhs, ConjugateRhs>::ResScalar, Index, Index, Index, Index) [with LhsScalar = double; RhsScalar = double; Index = long int; DataMapper = Eigen::internal::blas_data_mapper<double, long int, 0, 0>; int mr = 4; int nr = 4; bool ConjugateLhs = false; bool ConjugateRhs = false]':

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1418:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(0);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1419:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(1);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1420:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(2);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1421:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(3);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1423:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(4);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1424:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(5);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1425:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(6);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1426:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(7);

             ^~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1395:104: error: inconsistent operand constraints in an 'asm'

             #define EIGEN_GEBP_2PX4_SPILLING_WORKAROUND __asm__  ("" : [a0] "+rm" (A0),[a1] "+rm" (A1));

                                                                                                        ^

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1413:15: note: in expansion of macro 'EIGEN_GEBP_2PX4_SPILLING_WORKAROUND'

               EIGEN_GEBP_2PX4_SPILLING_WORKAROUND                               \

               ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

/var/jenkins_home/workspace/neon_PR-125-SEMONSAXNP4DJH6WB6FH3YM56CLGTVEOFZ5NHXEJWRZCJENGXRBQ@4/build/eigen3/src/eigen3/Eigen/src/Core/products/GeneralBlockPanelKernel.h:1437:13: note: in expansion of macro 'EIGEN_GEBGP_ONESTEP'

             EIGEN_GEBGP_ONESTEP(0);

             ^~~~~~~~~~~~~~~~~~~

make[2]: *** [src/CMakeFiles/neon.dir/build.make:115: src/CMakeFiles/neon.dir/constitutive/mechanics/plane/finite_strain_J2_plasticity.cpp.o] Error 1

make[1]: *** [CMakeFiles/Makefile2:1980: src/CMakeFiles/neon.dir/all] Error 2

make: *** [Makefile:141: all] Error 2

script returned exit code 2
Comment 1 Gael Guennebaud 2018-12-11 12:27:41 UTC
ok the trick to reproduce was to disable compiler optimizations, fixed:

https://bitbucket.org/eigen/eigen/commits/88fc23324517/
Comment 2 Darcy 2018-12-11 13:03:57 UTC
Thanks, will this be backported to the latest release?  I'd rather drop off from following Eigen head since I get a breakages from time to time.
Comment 3 Christoph Hertzberg 2018-12-11 14:36:41 UTC
I pushed the corresponding commits to the 3.3 branch. Since this is quite severe, guess this justifies a new release (and we must remember to also run the test-suite also in debug-mode before releases ...)
Comment 4 Gael Guennebaud 2018-12-11 17:53:14 UTC
my bad. I'll do a 3.3.7 tonight.
Comment 5 Christoph Hertzberg 2018-12-25 19:54:25 UTC
*** Bug 1651 has been marked as a duplicate of this bug. ***
Comment 6 Nobody 2019-12-04 18:16:23 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/1643.