This bugzilla service is closed. All entries have been migrated to https://gitlab.com/libeigen/eigen

Bug 1163

Summary: Sparse block assignment
Product: Eigen Reporter: Krishna Kanth Nakka <krishkanth.92>
Component: SparseAssignee: Nobody <eigen.nobody>
Status: RESOLVED DUPLICATE    
Severity: Documentation CC: chtz, gael.guennebaud, krishkanth.92
Priority: Normal    
Version: 3.3 (current stable)   
Hardware: x86 - 64-bit   
OS: Windows   
Whiteboard:

Description Krishna Kanth Nakka 2016-02-03 05:47:42 UTC
Hi,


In the documentation of 3.3 beta version,

One of the performance improvements in sparse module- 

***Optimize assignment into a Block<SparseMatrix> by using Ref and avoiding useless updates in non-compressed mode. This make row-by-row filling of a row-major sparse matrix very efficient.


Can anyone help me in understanding it. I'm unable to assign  a block submatrix from a sparse matrix  to a block in other sparse matrix.
Comment 1 Gael Guennebaud 2016-02-03 14:01:46 UTC
For a column-major matrix, you can only write to col(), middleCols() and for a row-major matrix to row(),middleRows(). And in general innerVector() and innerVectors() are always writeable.

See bug 305.
Comment 3 Gael Guennebaud 2016-02-03 14:05:36 UTC

*** This bug has been marked as a duplicate of bug 828 ***
Comment 4 Nobody 2019-12-04 15:25:12 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to gitlab.com's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.com/libeigen/eigen/issues/1163.