Eigen  3.3.7

Detailed Description

This module provides an interface to the SuperLU library. It provides the following factorization class:

Warning
This wrapper requires at least versions 4.0 of SuperLU. The 3.x versions are not supported.
When including this module, you have to use SUPERLU_EMPTY instead of EMPTY which is no longer defined because it is too polluting.
#include <Eigen/SuperLUSupport>

In order to use this module, the superlu headers must be accessible from the include paths, and your binary must be linked to the superlu library and its dependencies. The dependencies depend on how superlu has been compiled. For a cmake based project, you can use our FindSuperLU.cmake module to help you in this task.

Classes

class  Eigen::SuperILU< _MatrixType >
 A sparse direct incomplete LU factorization and solver based on the SuperLU library. More...
 
class  Eigen::SuperLU< _MatrixType >
 A sparse direct LU factorization and solver based on the SuperLU library. More...
 
class  Eigen::SuperLUBase< _MatrixType, Derived >
 The base class for the direct and incomplete LU factorization of SuperLU. More...