New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Bug 996 - Quaternation cannot be used with non-implicitly convertible scalars
Summary: Quaternation cannot be used with non-implicitly convertible scalars
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Geometry (show other bugs)
Version: 3.2
Hardware: All All
: Normal Compilation Problem
Assignee: Nobody
URL:
Whiteboard:
Keywords:
: 1020 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-14 15:01 UTC by Sergiu Deitsch
Modified: 2015-06-08 07:27 UTC (History)
5 users (show)



Attachments
Patch (754 bytes, patch)
2015-04-14 15:01 UTC, Sergiu Deitsch
no flags Details | Diff

Description Sergiu Deitsch 2015-04-14 15:01:05 UTC
Created attachment 563 [details]
Patch

Using ceres::Jet<> in combination with Eigen::Quaternion<> results in compilation errors, since scalars are not implicitly convertible to objects of type ceres::Jet. The patch fixes this problem.
Comment 1 Gael Guennebaud 2015-04-15 12:52:20 UTC
Thanks for the patch.

Applied in 3.2 and devel branches:

https://bitbucket.org/eigen/eigen/commits/ec9066c59246/
https://bitbucket.org/eigen/eigen/commits/86756935a955/
Comment 2 Christoph Hertzberg 2015-06-08 07:27:01 UTC
*** Bug 1020 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.