New user self-registration is currently disabled. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Bug 901 - SparseMatrixBase::triangularView<Unit*>() does not work for rectangular matrices
SparseMatrixBase::triangularView<Unit*>() does not work for rectangular matrices
Status: RESOLVED FIXED
Product: Eigen
Classification: Unclassified
Component: Sparse
3.3 (current stable)
All All
: High Crash
Assigned To: Nobody
:
Depends on:
Blocks: 3.3
  Show dependency treegraph
 
Reported: 2014-10-31 17:11 UTC by Christoph Hertzberg
Modified: 2016-02-12 15:11 UTC (History)
2 users (show)



Attachments

Description Christoph Hertzberg 2014-10-31 17:11:02 UTC
The problem is that the iterator tries to insert a 1 element for every innerVector, even if the inner dimension is smaller than the current inner Index.
Comment 1 Christoph Hertzberg 2014-10-31 17:12:57 UTC
I extended the sparse_basic unit tests (failing case is deactivated at the moment):
https://bitbucket.org/eigen/eigen/commits/1a08571a
Comment 2 Gael Guennebaud 2016-02-12 15:11:59 UTC
https://bitbucket.org/eigen/eigen/commits/2cd6a396a05c/

Note You need to log in before you can comment on or make changes to this bug.