New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Before reporting a bug, please make sure that your Eigen version is up-to-date!
Bug 825 - Explicitly warn about pitfalls with the auto keyword in C++11
Summary: Explicitly warn about pitfalls with the auto keyword in C++11
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 3.2
Hardware: All All
: High Documentation
Assignee: Nobody
URL:
Whiteboard:
Keywords: JuniorJob
: 434 (view as bug list)
Depends on:
Blocks: 3.3 505
  Show dependency treegraph
 
Reported: 2014-06-16 17:49 UTC by Christoph Hertzberg
Modified: 2015-09-02 09:25 UTC (History)
4 users (show)



Attachments

Description Christoph Hertzberg 2014-06-16 17:49:13 UTC
Storing expression trees using C++11's auto keyword can lead to strange pitfalls, non-working or inefficient code.
Some examples are bug 434, bug 505, bug 680 and various mailing list questions.

Some non-working code will be fixed by bug 99, but still some inefficient code will remain -- while sometimes the use of auto can be valid.

I'd think the best we can do for now is to explain this issue prominently in our documentation and link to it from as many places as possible.
Comment 1 Christoph Hertzberg 2014-11-02 18:37:43 UTC
*** Bug 434 has been marked as a duplicate of this bug. ***
Comment 2 Gael Guennebaud 2015-09-02 09:25:02 UTC
https://bitbucket.org/eigen/eigen/commits/457f41547e4f/
Summary:     Add a documentation page for common pitfalls

Note You need to log in before you can comment on or make changes to this bug.