New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Before reporting a bug, please make sure that your Eigen version is up-to-date!
Bug 750 - Forbid decompositions that depend on unsupported operations
Summary: Forbid decompositions that depend on unsupported operations
Status: RESOLVED DUPLICATE of bug 949
Alias: None
Product: Eigen
Classification: Unclassified
Component: General (show other bugs)
Version: 3.2
Hardware: All All
: Normal Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 3.3 949
  Show dependency treegraph
 
Reported: 2014-02-25 13:36 UTC by Christoph Hertzberg
Modified: 2015-03-13 21:05 UTC (History)
2 users (show)



Attachments

Description Christoph Hertzberg 2014-02-25 13:36:56 UTC
Currently, all decompositions can be called on integer matrices but usually generate bogus results, since they use floating point operations (division/sqrt) which are silently converted to integer results.
We should forbid such decompositions at compile-time.
Decompositions which only depend on division (LU/LDLt) should be allowed for rational-number implementations, however.
Comment 1 Gael Guennebaud 2014-10-20 13:58:40 UTC
At least, we should document the requirements on the Scalar types and explicitly list the common supported types.
Comment 2 Christoph Hertzberg 2015-03-13 21:05:50 UTC

*** This bug has been marked as a duplicate of bug 949 ***

Note You need to log in before you can comment on or make changes to this bug.