Bug 186 - Test failures with MatrixXcf on GCC 4.3 32bit with SSE2
: Test failures with MatrixXcf on GCC 4.3 32bit with SSE2
Status: RESOLVED FIXED
Product: Eigen
Classification: Unclassified
Component: Core - general
: unspecified
: x86 - 32-bit All
: --- normal
Assigned To: Nobody
:
:
:
:
: 3.0
  Show dependency treegraph
 
Reported: 2011-02-16 16:05 UTC by Benoit Jacob
Modified: 2011-02-18 15:43 UTC (History)
3 users (show)



Attachments

Description Benoit Jacob 2011-02-16 16:05:03 UTC
This comes from bug 89 comment 37:

=== BEGIN QUOTE ===

These tests are failing for me:
product_extra_3, product_symm_7, product_trmv_4, product_trsolve_3,
stable_norm_1, (nullary_4)

nullary_4 failed only once, but passed all the other times I tried, even with
r1000000.

stable_norm_1 is probably not critical - the test fails because norm() gives
the correct result

product_extra_3 failure has a different feel to it so probably another bug.

=== END QUOTE ===

These failures happen only in 32bit with SSE2 enabled.

On my 64bit system, I can reproduce with -m32 -msse2, but -m32 alone doesn't
reproduce, and -mfpmath=387 doesn't reproduce either.

Happens on both GCC 4.3.3 and 4.3.5.
Comment 1 Benoit Jacob 2011-02-16 16:14:16 UTC
The problem doesn't exist with GCC 4.4.5.
Comment 2 Gael Guennebaud 2011-02-18 15:43:27 UTC
fixed by changeset 268e6271fbfc

Note You need to log in before you can comment on or make changes to this bug.