New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Before reporting a bug, please make sure that your Eigen version is up-to-date!
Bug 135 - MSVC does not automatically enable SSE3/4.1/4.2
Summary: MSVC does not automatically enable SSE3/4.1/4.2
Status: RESOLVED DUPLICATE of bug 136
Alias: None
Product: Eigen
Classification: Unclassified
Component: Core - general (show other bugs)
Version: 3.0
Hardware: All All
: --- Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-16 16:02 UTC by Hauke Heibel
Modified: 2010-12-16 16:13 UTC (History)
2 users (show)



Attachments

Description Hauke Heibel 2010-12-16 16:02:30 UTC
MSVC does not define __SSE3__ and other related macros but it is automatically including the SSE header files, when the header <intrin.h> is included which we do in Eigen/Core.

Since all available SSE headers are included, the include guards should be available and set after including <intrin.h>. I created a patch which checks for the respective include guards and then define the corresponding Eigen definitions (EIGEN_VECTORIZE_SSE3, ...).

A patch is attached.
Comment 1 Hauke Heibel 2010-12-16 16:13:22 UTC

*** This bug has been marked as a duplicate of bug 136 ***

Note You need to log in before you can comment on or make changes to this bug.