New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Before reporting a bug, please make sure that your Eigen version is up-to-date!
Bug 1321 - Segmentation fault on simple -A*b operation
Summary: Segmentation fault on simple -A*b operation
Status: RESOLVED DUPLICATE of bug 1311
Alias: None
Product: Eigen
Classification: Unclassified
Component: Core - matrix products (show other bugs)
Version: 3.3 (current stable)
Hardware: x86 - 64-bit Linux
: High Crash
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-06 11:33 UTC by Arturo Laurenzi
Modified: 2016-10-12 14:54 UTC (History)
3 users (show)



Attachments
Example code (672 bytes, text/x-c++src)
2016-10-06 11:33 UTC, Arturo Laurenzi
no flags Details

Description Arturo Laurenzi 2016-10-06 11:33:57 UTC
Created attachment 744 [details]
Example code

OS: Ubuntu 16.04 LTS
COMPILER: default version of gcc shipping with the OS (5.4.0)

Computing -A*b gives segmentation fault if:
 - A is a dynamically-allocated matrix with an ODD number of rows
 - b is a statically-allocated vector

As the attachment shows, if A has an EVEN number of rows everything is alright
If b is dynamically-allocated everything is alright.
Comment 1 Gael Guennebaud 2016-10-12 14:49:37 UTC
I cannot reproduce. What are your compiler flags?
Comment 2 Gael Guennebaud 2016-10-12 14:54:14 UTC
ok, that fails with rc1, but this has already been fixed.

*** This bug has been marked as a duplicate of bug 1311 ***

Note You need to log in before you can comment on or make changes to this bug.