New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Before reporting a bug, please make sure that your Eigen version is up-to-date!
Bug 1305 - Implementation of additional component-wise unary functions
Summary: Implementation of additional component-wise unary functions
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Core - expression templates (show other bugs)
Version: 3.4 (development)
Hardware: All All
: Normal Feature Request
Assignee: Nobody
URL:
Whiteboard:
Keywords:
: 1653 (view as bug list)
Depends on:
Blocks: 3.4
  Show dependency treegraph
 
Reported: 2016-09-23 07:05 UTC by Matthias Moeller
Modified: 2019-01-16 13:22 UTC (History)
4 users (show)



Attachments
Implementation of additional component-wise unary functions (25.79 KB, patch)
2016-09-23 07:05 UTC, Matthias Moeller
no flags Details | Diff

Description Matthias Moeller 2016-09-23 07:05:21 UTC
Created attachment 737 [details]
Implementation of additional component-wise unary functions

Dear all,

for one of my projects I implemented the following additional component-wise unary functions that are not present in the release 3.2.9:

atan, log10, sinh, asinh, cosh, acosh, tanh, atanh, erf, erfc, ceil, floor, round, trunc

Implementation strictly follows the way that cos, sin, etc. are implemented, that is, calls to MKL, etc. are implemented.

The attached patch has been tested for Eigen 3.2.9.

Kind regards,
Matthias
Comment 1 Christoph Hertzberg 2016-09-23 07:53:01 UTC
Could you please switch to the development branch?
We have several of them implemented -- partially in the unsupported/SpecialFunctions module. 
I think only asinh, acosh and atanh are missing.

The 3.2 branch shall mostly get bug fixes only.
Comment 2 Christoph Hertzberg 2018-12-27 23:27:05 UTC
*** Bug 1653 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Hertzberg 2018-12-27 23:30:19 UTC
The inverse hyperbolic functions have implementations, but it looks like they are not available via the public API.

Looks simple enough for 3.4
Comment 4 Gael Guennebaud 2019-01-16 13:22:14 UTC
Eventually, Rasmus did the work: https://bitbucket.org/eigen/eigen/commits/bf07dcddde

Note You need to log in before you can comment on or make changes to this bug.