New user self-registration is currently disabled. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Bug 1285 - Tests on ppc64le are failing
Tests on ppc64le are failing
Status: RESOLVED WORKSFORME
Product: Eigen
Classification: Unclassified
Component: Tests
3.3 (current stable)
PPC - general Linux
: Normal Failed Unit Test
Assigned To: Konstantinos Margaritis
:
Depends on:
Blocks: 3.3
  Show dependency treegraph
 
Reported: 2016-08-31 08:14 UTC by Thierry Fauck
Modified: 2016-11-24 13:59 UTC (History)
5 users (show)



Attachments

Description Thierry Fauck 2016-08-31 08:14:37 UTC
96% tests passed, 28 tests failed out of 769

Label Time Summary:
Official       = 280.47 sec (651 tests)
Unsupported    = 101.63 sec (105 tests)

Total Test time (real) = 574.65 sec

The following tests FAILED:
	 33 - packetmath_5 (OTHER_FAULT)
	111 - product_small_2 (OTHER_FAULT)
	354 - determinant_5 (OTHER_FAULT)
	355 - determinant_6 (OTHER_FAULT)
	440 - eigensolver_generalized_real_2 (OTHER_FAULT)
	441 - eigensolver_generalized_real_3 (OTHER_FAULT)
	471 - bdcsvd_9 (OTHER_FAULT)
	596 - sparselu_1 (OTHER_FAULT)
	597 - sparselu_2 (OTHER_FAULT)
	598 - sparselu_3 (OTHER_FAULT)
	599 - sparselu_4 (OTHER_FAULT)
	602 - umeyama_1 (OTHER_FAULT)
	603 - umeyama_2 (OTHER_FAULT)
	604 - umeyama_3 (OTHER_FAULT)
	605 - umeyama_4 (OTHER_FAULT)
	606 - umeyama_5 (OTHER_FAULT)
	607 - umeyama_6 (OTHER_FAULT)
	608 - umeyama_7 (OTHER_FAULT)
	609 - umeyama_8 (OTHER_FAULT)
	651 - fastmath (OTHER_FAULT)
	665 - NonLinearOptimization (OTHER_FAULT)
	686 - matrix_exponential_9 (OTHER_FAULT)
	696 - matrix_power_9 (OTHER_FAULT)
	699 - matrix_power_12 (OTHER_FAULT)
	715 - sparse_extra_3 (OTHER_FAULT)
	740 - levenberg_marquardt (OTHER_FAULT)
	758 - cxx11_tensor_casts (OTHER_FAULT)
	763 - cxx11_tensor_io (SEGFAULT)
Comment 1 Gael Guennebaud 2016-08-31 21:12:28 UTC
That's not good, but to get a bit more information on what is failing, could you run:

$ ctest -D Experimental

This will submit the outcome of the unit tests to our CDash (http://manao.inria.fr/CDash/index.php?project=Eigen&display=project).

Another solution would be to run "ctest -V" and attach the detailed log to this bug entry.

thanks.
Comment 2 Konstantinos Margaritis 2016-08-31 21:27:25 UTC
last time I checked there were failing tests but definitely not that many, I'm running the tests on my system now (debian/testing, gcc 5.4)
Comment 3 Thierry Fauck 2016-09-01 13:28:42 UTC
Performing coverage
 Cannot find any coverage files. Ignoring Coverage request.
Submit files (using http)
   Using HTTP submit method
   Drop site:http://manao.inria.fr/CDash/submit.php?project=Eigen
   Uploaded: /home/ubuntu/EIGEN/eigen-eigen-69d418c06999/build/Testing/20160901-1311/Build.xml
   Uploaded: /home/ubuntu/EIGEN/eigen-eigen-69d418c06999/build/Testing/20160901-1311/Configure.xml
   Uploaded: /home/ubuntu/EIGEN/eigen-eigen-69d418c06999/build/Testing/20160901-1311/Test.xml
   Submission successful
Errors while running CTest
Comment 4 Thierry Fauck 2016-09-01 13:29:24 UTC
Oups, I forgot to mention : gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/powerpc64le-linux-gnu/6/lto-wrapper
Target: powerpc64le-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 6.2.0-1ubuntu12' --with-bugurl=file:///usr/share/doc/gcc-6/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-6 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-libquadmath --enable-plugin --enable-default-pie --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-6-ppc64el/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-6-ppc64el --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-6-ppc64el --with-arch-directory=ppc64le --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-secureplt --with-cpu=power8 --enable-targets=powerpcle-linux --disable-multilib --enable-multiarch --disable-werror --with-long-double-128 --enable-checking=release --build=powerpc64le-linux-gnu --host=powerpc64le-linux-gnu --target=powerpc64le-linux-gnu
Thread model: posix
gcc version 6.2.0 20160824 (Ubuntu 6.2.0-1ubuntu12)
Comment 5 Thierry Fauck 2016-09-02 06:44:48 UTC
On Debian with gcc version 4.9.2 (Debian 4.9.2-10) 

96% tests passed, 27 tests failed out of 757

Label Time Summary:
Official       = 474.32 sec (651 tests)
Unsupported    = 120.22 sec (105 tests)

Total Test time (real) = 760.83 sec

The following tests FAILED:
	111 - product_small_2 (OTHER_FAULT)
	354 - determinant_5 (OTHER_FAULT)
	355 - determinant_6 (OTHER_FAULT)
	440 - eigensolver_generalized_real_2 (OTHER_FAULT)
	441 - eigensolver_generalized_real_3 (OTHER_FAULT)
	471 - bdcsvd_9 (OTHER_FAULT)
	596 - sparselu_1 (OTHER_FAULT)
	597 - sparselu_2 (OTHER_FAULT)
	598 - sparselu_3 (OTHER_FAULT)
	599 - sparselu_4 (OTHER_FAULT)
	602 - umeyama_1 (OTHER_FAULT)
	603 - umeyama_2 (OTHER_FAULT)
	604 - umeyama_3 (OTHER_FAULT)
	605 - umeyama_4 (OTHER_FAULT)
	606 - umeyama_5 (OTHER_FAULT)
	607 - umeyama_6 (OTHER_FAULT)
	608 - umeyama_7 (OTHER_FAULT)
	609 - umeyama_8 (OTHER_FAULT)
	651 - fastmath (OTHER_FAULT)
	653 - NonLinearOptimization (OTHER_FAULT)
	674 - matrix_exponential_9 (OTHER_FAULT)
	684 - matrix_power_9 (OTHER_FAULT)
	687 - matrix_power_12 (OTHER_FAULT)
	703 - sparse_extra_3 (OTHER_FAULT)
	728 - levenberg_marquardt (OTHER_FAULT)
	746 - cxx11_tensor_casts (OTHER_FAULT)
	751 - cxx11_tensor_io (SEGFAULT)
Errors while running CTest
Comment 6 Gael Guennebaud 2016-09-05 07:31:13 UTC
For the record, here is the direct link to the report:

http://manao.inria.fr/CDash/viewTest.php?onlyfailed&buildid=35063

There is an alignment issue in product_small_2 and the sparselu_* are odd as they all return a relative error of 256 exactly.
Comment 7 Gael Guennebaud 2016-09-07 20:12:03 UTC
Actually, NEON is exhibiting very similar errors:

http://manao.inria.fr/CDash/viewTest.php?onlyfailed&buildid=35263
Comment 8 Gael Guennebaud 2016-09-07 20:29:11 UTC
The last successful build for neon was on 2016-05-23 and it started to fail on 2016-05-27.

It would be nice is someone with easy access to either PPC or NEON could bisect on, e.g., umeyama_1.

There have been a huge amount of commits during these 4 days, but my guess is that the guilty commit is among those three:

6c2dc56e73b3
a2cd0e241553
8740505d2b57

If I'm right, simply defining EIGEN_UNALIGNED_VECTORIZE=0 should fix (hide) the issue.
Comment 9 Konstantinos Margaritis 2016-09-08 08:08:16 UTC
Just tried the umeyama tests with EIGEN_UNALIGNED_VECTORIZE=0 on ppc64le, it still didn't pass. In fact it would mean that there is an error in unaligned vectorization, would show up elsewhere as well, right?
Comment 10 Gael Guennebaud 2016-09-09 13:09:16 UTC
OK, then could you bisect between rev c0ff734c84f5 and rev de14376a69f8? I assume that umeyama_1 works with the first one but fails with the second. Thanks.
Comment 11 Konstantinos Margaritis 2016-09-11 14:48:19 UTC
I can confirm that it works on c0ff734c84f5 and breaks at 634dab7c40d0. I could investigate it a bit more and perhaps attempt a fix if pointed to the right direction/file.
Comment 12 Gael Guennebaud 2016-09-12 16:31:06 UTC
Could you bisect between those two?

$ hg up 634dab7c40d0
$ hg bisect -b
$ hg up c0ff734c84f5
$ hg bisect -g
$ make umeyama_1 && ./umeyama_1
$ hg bisect -g (good) or -b (bad) according to the outcome

repeat the last two steps until you got the first failing changeset (should be quick)

thanks.
Comment 13 Christoph Hertzberg 2016-09-12 16:43:02 UTC
ProTip (replacing the last two lines):
$ hg bisect -c "make umeyama_1 && ./umeyama_1"
Comment 14 Konstantinos Margaritis 2016-09-12 21:49:14 UTC
$ hg bisect -c "make umeyama_1 && ./umeyama_1"
Scanning dependencies of target umeyama_1
Building CXX object test/CMakeFiles/umeyama_1.dir/umeyama.cpp.o
Linking CXX executable umeyama_1
Built target umeyama_1
Initializing random number generator with seed 1473702479
Repeating each test 10 times
Test run_test<MatrixXd>(dim, num_elements) failed in /home/markos/Development/eigen/test/umeyama.cpp (117)
    error < Scalar(40)*std::numeric_limits<Scalar>::epsilon()
Stack:
  - run_test<MatrixXd>(dim, num_elements)
  - umeyama
  - Seed: 1473702479

Aborted
changeset 8762:6c00c9378f16: bad
The first bad revision is:
changeset:   8762:6c00c9378f16
user:        Gael Guennebaud <g.gael@free.fr>
date:        Thu May 26 17:34:23 2016 +0200
summary:     Store permutation's determinant as char.
Comment 15 Gael Guennebaud 2016-09-13 06:04:56 UTC
What an embarrassing mistake of mine!

Should be fixed:
https://bitbucket.org/eigen/eigen/commits/3806ea6d2b5d/
Summary:     Bug 1285: fix regression introduced in changeset 6c00c9378f16
Comment 16 Konstantinos Margaritis 2016-09-13 06:12:04 UTC
Confirmed that it works on ppc64le, running a full make check again.
Comment 17 Konstantinos Margaritis 2016-09-13 07:56:51 UTC
ok, down to "just" 11 failures:
        113 - product_small_2 (OTHER_FAULT)
        475 - bdcsvd_9 (OTHER_FAULT)
        655 - fastmath (OTHER_FAULT)
        657 - NonLinearOptimization (OTHER_FAULT)
        678 - matrix_exponential_9 (OTHER_FAULT)
        688 - matrix_power_9 (OTHER_FAULT)
        691 - matrix_power_12 (OTHER_FAULT)
        710 - sparse_extra_3 (OTHER_FAULT)
        735 - levenberg_marquardt (OTHER_FAULT)
        754 - cxx11_tensor_casts (OTHER_FAULT)
        759 - cxx11_tensor_io (SEGFAULT)

thanks Gael!
Comment 18 Gael Guennebaud 2016-09-14 16:38:28 UTC
Only product_small_2 is really annoying. I guess you're observing something like:



product_small_2: .../Eigen/src/Core/MapBase.h:191: void Eigen::MapBase<Derived, 0>::checkSanity(typename Eigen::internal::enable_if<(Eigen::internal::traits<OtherDerived>::Alignment > 0), void*>::type) const [with T = Eigen::Map<Eigen::Matrix<int, -1, 1>, 16, Eigen::Stride<0, 0> >; Derived = Eigen::Map<Eigen::Matrix<int, -1, 1>, 16, Eigen::Stride<0, 0> >; typename Eigen::internal::enable_if<(Eigen::internal::traits<OtherDerived>::Alignment > 0), void*>::type = void*]: Assertion `( ((internal::UIntPtr(m_data) % internal::traits<Derived>::Alignment) == 0) || (cols() * rows() * innerStride() * sizeof(Scalar)) < internal::traits<Derived>::Alignment ) && "data is not aligned"' failed.


The backtrace might help to track down the issue. Thanks. You could also add the following before the assert to see what's going on:

std::cerr << cols() << " " << rows() << " " << innerStride() << " " << sizeof(Scalar) << " ; " << internal::UIntPtr(m_data) << " " << internal::traits<Derived>::Alignment << "\n";

Thanks again for your time.
Comment 19 Gael Guennebaud 2016-09-14 16:39:19 UTC
I'm thus re-opening.
Comment 20 Konstantinos Margaritis 2016-09-15 13:22:32 UTC
here is the output with the extra info:

$ ./test/product_small_2
Initializing random number generator with seed 1473945694
Repeating each test 10 times
1 5 1 4 ; 70368156858376 16
product_small_2: /home/markos/Development/eigen/Eigen/src/Core/MapBase.h:194: void Eigen::MapBase<Derived, 0>::checkSanity(typename Eigen::internal::enable_if<(Eigen::internal::traits<OtherDerived>::Alignment > 0), void*>::type) const [with T = Eigen::Map<Eigen::Matrix<int, -1, 1>, 16, Eigen::Stride<0, 0> >; Derived = Eigen::Map<Eigen::Matrix<int, -1, 1>, 16, Eigen::Stride<0, 0> >; typename Eigen::internal::enable_if<(Eigen::internal::traits<OtherDerived>::Alignment > 0), void*>::type = void*]: Assertion `( ((internal::UIntPtr(m_data) % internal::traits<Derived>::Alignment) == 0) || (cols() * rows() * innerStride() * sizeof(Scalar)) < internal::traits<Derived>::Alignment ) && "data is not aligned"' failed.
Comment 21 Gael Guennebaud 2016-09-15 14:08:34 UTC
Thanks, the backtrace would help.
Comment 22 Gael Guennebaud 2016-09-16 11:46:07 UTC
I cannot reproduce. I tried on a POWER7 with a Fedora and gcc 4.8, using the following flags:

-pedantic -Wall -Wextra -Wundef -Wcast-align -Wchar-subscripts -Wnon-virtual-dtor -Wunused-local-typedefs -Wpointer-arith -Wwrite-strings -Wformat-security -Wlogical-op -Wdouble-promotion -Wno-psabi -Wno-variadic-macros -Wno-long-long -fno-check-new -fno-common -fstrict-aliasing -ansi -maltivec -mabi=altivec -O3 -DNDEBUG

I run product_small_2 several times, it never failed.
Comment 23 Gael Guennebaud 2016-09-16 12:15:03 UTC
I also cannot reproduce on an IBM POWER System S822, fedora 21 ppc64le, gcc 4.9, with the following flags:

-pedantic -Wall -Wextra -Wundef -Wcast-align -Wchar-subscripts -Wnon-virtual-dtor -Wunused-local-typedefs -Wpointer-arith -Wwrite-strings -Wformat-security -Wlogical-op -Wdouble-promotion -Wno-psabi -Wno-variadic-macros -Wno-long-long -fno-check-new -fno-common -fstrict-aliasing -ansi -m64 -mvsx -O3 -DNDEBUG
Comment 24 Gael Guennebaud 2016-09-17 12:14:43 UTC
Fixed : https://bitbucket.org/eigen/eigen/commits/41ceedad023b/
Summary:     Fix alignement of statically allocated temporaries in gemv.
Comment 25 Thierry Fauck 2016-10-06 06:52:34 UTC
AFter applying both patches 
https://bitbucket.org/eigen/eigen/commits/3806ea6d2b5d/ and
https://bitbucket.org/eigen/eigen/commits/41ceedad023b/
I get following results : 97% tests passed, 23 tests failed out of 770

Label Time Summary:
Official       = 279.81 sec (652 tests)
Unsupported    = 102.17 sec (105 tests)

Total Test time (real) = 619.96 sec

The following tests FAILED:
	  6 - nomalloc_2 (OTHER_FAULT)
	  7 - nomalloc_3 (OTHER_FAULT)
	 33 - packetmath_5 (OTHER_FAULT)
	441 - eigensolver_generalized_real_2 (OTHER_FAULT)
	442 - eigensolver_generalized_real_3 (OTHER_FAULT)
	472 - bdcsvd_9 (OTHER_FAULT)
	526 - geo_homogeneous_1 (OTHER_FAULT)
	652 - fastmath (OTHER_FAULT)
	655 - sblat2 (Failed)
	656 - sblat3 (Failed)
	658 - dblat2 (Failed)
	659 - dblat3 (Failed)
	661 - cblat2 (Failed)
	664 - zblat2 (Failed)
	666 - NonLinearOptimization (OTHER_FAULT)
	687 - matrix_exponential_9 (OTHER_FAULT)
	697 - matrix_power_9 (OTHER_FAULT)
	700 - matrix_power_12 (OTHER_FAULT)
	716 - sparse_extra_3 (OTHER_FAULT)
	725 - polynomialsolver_9 (OTHER_FAULT)
	741 - levenberg_marquardt (OTHER_FAULT)
	759 - cxx11_tensor_casts (OTHER_FAULT)
	764 - cxx11_tensor_io (SEGFAULT)

so some bugs are fixed but more bugs are failing - so reopeing unless I made a mistake
Thx
Comment 26 Konstantinos Margaritis 2016-10-06 10:42:41 UTC
I just ran a make check on tip and got the same as before:

The following tests FAILED:
        476 - bdcsvd_9 (OTHER_FAULT)
        657 - fastmath (OTHER_FAULT)
        659 - NonLinearOptimization (OTHER_FAULT)
        680 - matrix_exponential_9 (OTHER_FAULT)
        690 - matrix_power_9 (Timeout)
        693 - matrix_power_12 (Timeout)
        705 - alignedvector3 (OTHER_FAULT)
        712 - sparse_extra_3 (OTHER_FAULT)
        737 - levenberg_marquardt (OTHER_FAULT)
        761 - cxx11_tensor_io (SEGFAULT)

I think alignedvector3 needs to be looked at as it's new, but the rest are pretty much the same as before. Maybe you forgot to pick some extra patches? What compiler do you use (gcc 6.1.1 here)? Do you get the same failures on tip?
Comment 27 Benoit Steiner 2016-10-07 16:53:11 UTC
The alignedvector3 test is failing on several other platforms as well. For example, it failed last night on x86_64 with gcc 5.3 http://manao.inria.fr/CDash/viewTest.php?onlyfailed&buildid=36280 and on Windows 7 with MSVC 14 (http://manao.inria.fr/CDash/viewTest.php?onlyfailed&buildid=36276)
Comment 28 Benoit Steiner 2016-10-07 18:32:26 UTC
Below is the stack trace for the alignedvector3 test failure on Ubuntu 14.04 with gcc 4.8 and AVX turned on. A dynamic stride is computed to be 4, but it's statically expected to be 3 (which makes sense we're we're processing vectors of 3 elements), thus triggering a debug assertion.

#0  0x00007ffff722bc37 in __GI_raise (sig=sig@entry=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#1  0x00007ffff722f028 in __GI_abort () at abort.c:89
#2  0x00007ffff7224bf6 in __assert_fail_base (
    fmt=0x7ffff73753b8 "%s%s%s:%u: %s%sAssertion `%s' failed.\n%n", 
    assertion=assertion@entry=0x4dcd92 "v == T(Value)", 
    file=file@entry=0x4dcd40 "eigen/Eigen/src/Core/util/XprHelper.h", line=line@entry=110, 
    function=function@entry=0x4dd800 <Eigen::internal::variable_if_dynamic<long, 3>::variable_if_dynamic(long)::__PRETTY_FUNCTION__> "Eigen::internal::variable_if_dynamic<T, Value>::variable_if_dynamic(T) [with T = long int; int Value = 3]") at assert.c:92
#3  0x00007ffff7224ca2 in __GI___assert_fail (
    assertion=0x4dcd92 "v == T(Value)", 
    file=0x4dcd40 "eigen/Eigen/src/Core/util/XprHelper.h", line=110, 
    function=0x4dd800 <Eigen::internal::variable_if_dynamic<long, 3>::variable_if_dynamic(long)::__PRETTY_FUNCTION__> "Eigen::internal::variable_if_dynamic<T, Value>::variable_if_dynamic(T) [with T = long int; int Value = 3]")
    at assert.c:101
#4  0x00000000004b73f6 in Eigen::internal::variable_if_dynamic<long, 3>::variable_if_dynamic (this=0x7fffffffd049, v=4)
    at eigen/Eigen/src/Core/util/XprHelper.h:110
#5  0x00000000004dbabc in Eigen::internal::mapbase_evaluator<Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true>, Eigen::Matrix<float, 3, 1, 0, 3, 1> >::mapbase_evaluator (this=0x7fffffffd040, map=...)
    at eigen/Eigen/src/Core/CoreEvaluators.h:824
#6  0x00000000004db5ce in Eigen::internal::block_evaluator<Eigen::AlignedVector3<float> const, 3, 1, true, true>::block_evaluator (this=0x7fffffffd040, 
    block=...)
    at eigen/Eigen/src/Core/CoreEvaluators.h:1104
#7  0x00000000004db109 in Eigen::internal::evaluator<Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> >::evaluator (this=0x7fffffffd040, block=...)
    at eigen/Eigen/src/Core/CoreEvaluators.h:994
#8  0x00000000004dabeb in Eigen::internal::evaluator<Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> const>::evaluator (this=0x7fffffffd040, 
    xpr=...)
    at eigen/Eigen/src/Core/CoreEvaluators.h:103
#9  0x00000000004da495 in Eigen::internal::binary_evaluator<Eigen::CwiseBinaryOp<Eigen::internal::scalar_product_op<float, float>, Eigen::Transpose<Eigen::Block<Eigen::Matrix<float, 3, 3, 0, 3, 3> const, 1, 3, false> const> const, Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> const>, Eigen::internal::IndexBased, Eigen::internal::IndexBased, float, float>::binary_evaluator (
    this=0x7fffffffd020, xpr=...)
    at eigen/Eigen/src/Core/CoreEvaluators.h:702
#10 0x00000000004d95ef in Eigen::internal::evaluator<Eigen::CwiseBinaryOp<Eigen::internal::scalar_product_op<float, float>, Eigen::Transpose<Eigen::Block<Eigen::Matrix<float, 3, 3, 0, 3, 3> const, 1, 3, false> const> const, Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> const> >::evaluator (
---Type <return> to continue, or q <return> to quit---
    this=0x7fffffffd020, xpr=...)
    at eigen/Eigen/src/Core/CoreEvaluators.h:671
#11 0x00000000004d8bed in Eigen::internal::redux_evaluator<Eigen::CwiseBinaryOp<Eigen::internal::scalar_product_op<float, float>, Eigen::Transpose<Eigen::Block<Eigen::Matrix<float, 3, 3, 0, 3, 3> const, 1, 3, false> const> const, Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> const> >::redux_evaluator (
    this=0x7fffffffd020, xpr=...)
    at eigen/Eigen/src/Core/Redux.h:338
#12 0x00000000004d80b0 in Eigen::DenseBase<Eigen::CwiseBinaryOp<Eigen::internal::scalar_product_op<float, float>, Eigen::Transpose<Eigen::Block<Eigen::Matrix<float, 3, 3, 0, 3, 3> const, 1, 3, false> const> const, Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> const> >::redux<Eigen::internal::scalar_sum_op<float, float> > (this=0x7fffffffd160, func=...)
    at eigen/Eigen/src/Core/Redux.h:416
#13 0x00000000004d6a4f in Eigen::DenseBase<Eigen::CwiseBinaryOp<Eigen::internal::scalar_product_op<float, float>, Eigen::Transpose<Eigen::Block<Eigen::Matrix<float, 3, 3, 0, 3, 3> const, 1, 3, false> const> const, Eigen::Block<Eigen::AlignedVector3<float> const, 3, 1, true> const> >::sum (this=0x7fffffffd160)
    at eigen/Eigen/src/Core/Redux.h:453
#14 0x00000000004d5f97 in Eigen::internal::product_evaluator<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1>, 3, Eigen::DenseShape, Eigen::DenseShape, float, float>::coeff (this=0x7fffffffd2f0, row=0, 
    col=0)
    at eigen/Eigen/src/Core/ProductEvaluators.h:536
#15 0x00000000004d59c9 in Eigen::internal::generic_dense_assignment_kernel<Eigen::internal::evaluator<Eigen::Matrix<float, 3, 1, 0, 3, 1> >, Eigen::internal::evaluator<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1> >, Eigen::internal::assign_op<float, float>, 0>::assignCoeff (
    this=0x7fffffffd2d0, row=0, col=0)
    at eigen/Eigen/src/Core/AssignEvaluator.h:631
#16 0x00000000004d53e1 in Eigen::internal::generic_dense_assignment_kernel<Eigen::internal::evaluator<Eigen::Matrix<float, 3, 1, 0, 3, 1> >, Eigen::internal::evaluator<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1> >, Eigen::internal::assign_op<float, float>, 0>::assignCoeffByOuterInner (this=0x7fffffffd2d0, outer=0, inner=0)
    at eigen/Eigen/src/Core/AssignEvaluator.h:645
#17 0x00000000004d490b in Eigen::internal::copy_using_evaluator_DefaultTraversal_CompleteUnrolling<Eigen::internal::generic_dense_assignment_kernel<Eigen::internal::evaluator<Eigen::Matrix<float, 3, 1, 0, 3, 1> >, Eigen::internal::evaluator<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1> >, Eigen::internal::assign_op<float, float>, 0>, 0, 3>::run (kernel=...)
    at eigen/Eigen/src/Core/AssignEvaluator.h:206
#18 0x00000000004d3a6f in Eigen::internal::dense_assignment_loop<Eigen::internal::generic_dense_assignment_kernel<Eigen::internal::evaluator<Eigen::Matrix<float, 3, 1, 0, 3, 1> >, Eigen::internal::evaluator<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1> >, Eigen::internal::assign_op<float, float>, 0>, 3, 2>::run (kernel=...)
---Type <return> to continue, or q <return> to quit---
    at eigen/Eigen/src/Core/AssignEvaluator.h:435
#19 0x00000000004d1db6 in Eigen::internal::call_dense_assignment_loop<Eigen::Matrix<float, 3, 1, 0, 3, 1>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1>, Eigen::internal::assign_op<float, float> > (
    dst=..., src=..., func=...)
    at eigen/Eigen/src/Core/AssignEvaluator.h:713
#20 0x00000000004cf9cd in Eigen::internal::Assignment<Eigen::Matrix<float, 3, 1, 0, 3, 1>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1>, Eigen::internal::assign_op<float, float>, Eigen::internal::Dense2Dense, void>::run (dst=..., src=..., func=...)
    at eigen/Eigen/src/Core/AssignEvaluator.h:862
#21 0x00000000004cd502 in Eigen::internal::call_assignment_no_alias<Eigen::Matrix<float, 3, 1, 0, 3, 1>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 1>, Eigen::internal::assign_op<float, float> > (
    dst=..., src=..., func=...)
    at eigen/Eigen/src/Core/AssignEvaluator.h:813
#22 0x00000000004ca386 in Eigen::internal::generic_product_impl<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, Eigen::DenseShape, Eigen::DenseShape, 3>::evalTo<Eigen::Matrix<float, 3, 1, 0, 3, 1> > (dst=..., lhs=..., 
    rhs=...)
    at eigen/Eigen/src/Core/ProductEvaluators.h:381
#23 0x00000000004c6ca4 in Eigen::internal::Assignment<Eigen::Matrix<float, 3, 1, 0, 3, 1>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0>, Eigen::internal::assign_op<float, float>, Eigen::internal::Dense2Dense, void>::run (dst=..., src=...)
    at eigen/Eigen/src/Core/ProductEvaluators.h:144
#24 0x00000000004c3ae0 in Eigen::internal::call_assignment_no_alias<Eigen::Matrix<float, 3, 1, 0, 3, 1>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0>, Eigen::internal::assign_op<float, float> > (
    dst=..., src=..., func=...)
    at eigen/Eigen/src/Core/AssignEvaluator.h:813
#25 0x00000000004c0215 in Eigen::PlainObjectBase<Eigen::Matrix<float, 3, 1, 0, 3, 1> >::_set_noalias<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0> > (this=0x7fffffffd580, other=...)
    at eigen/Eigen/src/Core/PlainObjectBase.h:721
#26 0x00000000004ba8f7 in Eigen::PlainObjectBase<Eigen::Matrix<float, 3, 1, 0, 3, 1> >::_init1<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0> > (this=0x7fffffffd580, other=...)
    at eigen/Eigen/src/Core/PlainObjectBase.h:804
#27 0x00000000004b7c42 in Eigen::Matrix<float, 3, 1, 0, 3, 1>::Matrix<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0> > (
    this=0x7fffffffd580, x=...)
    at eigen/Eigen/src/Core/Matrix.h:296
#28 0x00000000004ba7b3 in Eigen::internal::isApprox_selector<Eigen::Product<Eige---Type <return> to continue, or q <return> to quit---
n::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::Matrix<float, 3, 1, 0, 3, 1>, 0>, false>::run (x=..., y=..., prec=@0x7fffffffd68c: 0.00100000005)
    at eigen/Eigen/src/Core/Fuzzy.h:25
#29 0x00000000004b7bf9 in Eigen::DenseBase<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0> >::isApprox<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::Matrix<float, 3, 1, 0, 3, 1>, 0> > (
    this=0x7fffffffd880, other=..., prec=@0x7fffffffd68c: 0.00100000005)
    at eigen/Eigen/src/Core/Fuzzy.h:108
#30 0x00000000004b3ccf in Eigen::test_isApprox<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::Matrix<float, 3, 1, 0, 3, 1>, 0> > (a=..., 
    b=...)
    at eigen/unsupported/test/../../test/main.h:457
#31 0x00000000004b0631 in Eigen::verifyIsApprox<Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::AlignedVector3<float>, 0>, Eigen::Product<Eigen::Matrix<float, 3, 3, 0, 3, 3>, Eigen::Matrix<float, 3, 1, 0, 3, 1>, 0> > (a=..., 
    b=...)
    at eigen/unsupported/test/../../test/main.h:477
#32 0x00000000004aecf9 in alignedvector3<float> ()
    at eigen/unsupported/test/alignedvector3.cpp:48
#33 0x00000000004ad98e in test_alignedvector3 ()
    at eigen/unsupported/test/alignedvector3.cpp:82
#34 0x00000000004ad8b2 in main (argc=1, argv=0x7fffffffde88)
    at eigen/unsupported/test/../../test/main.h:725
Comment 29 Thierry Fauck 2016-10-10 10:31:25 UTC
I took current tree and run it - I am getting following output
98% tests passed, 12 tests failed out of 788

Label Time Summary:
Official       = 481.11 sec (667 tests)
Unsupported    = 1592.05 sec (108 tests)

Total Test time (real) = 2211.97 sec

The following tests FAILED:
	 34 - packetmath_5 (OTHER_FAULT)
	476 - bdcsvd_9 (OTHER_FAULT)
	657 - fastmath (OTHER_FAULT)
	681 - NonLinearOptimization (OTHER_FAULT)
	702 - matrix_exponential_9 (OTHER_FAULT)
	712 - matrix_power_9 (OTHER_FAULT)
	715 - matrix_power_12 (Timeout)
	727 - alignedvector3 (OTHER_FAULT)
	733 - sparse_extra_3 (OTHER_FAULT)
	742 - polynomialsolver_9 (OTHER_FAULT)
	758 - levenberg_marquardt (OTHER_FAULT)
	782 - cxx11_tensor_io (SEGFAULT)

so agree there are less tests in error, but why do I get a different list ?
Comment 30 Gael Guennebaud 2016-10-12 19:50:07 UTC
For alignedvector3: https://bitbucket.org/eigen/eigen/commits/0b513831e354/
Comment 31 Gael Guennebaud 2016-10-26 12:04:10 UTC
Here is what I get on a ppc64le with gcc 4.9:
http://manao.inria.fr/CDash/viewTest.php?onlyfailed&buildid=36783

so nothing wrong in the official tests (bdcsvd_9 and fastmath are expected).

In your case, only packetmath_5 is troublesome. Could you paste the output of running it manually to see what's really failling. Thanks.
Comment 32 Konstantinos Margaritis 2016-11-03 10:22:05 UTC
Just tested it again with current tip, all packetmath_* tests work fine, sorry can't reproduce here (Debian testing/g++ 6.2.x) on a Power8 VM.
Comment 33 Thierry Fauck 2016-11-24 13:59:50 UTC
Running on Ubuntu 1704 the dev. tree I got following results:
99% tests passed, 10 tests failed out of 770

Label Time Summary:
Official       = 299.99 sec (658 tests)
Unsupported    = 1607.53 sec (111 tests)

Total Test time (real) = 2092.55 sec

The following tests FAILED:
	477 - bdcsvd_9 (OTHER_FAULT)
	658 - fastmath (OTHER_FAULT)
	660 - NonLinearOptimization (OTHER_FAULT)
	681 - matrix_exponential_9 (OTHER_FAULT)
	691 - matrix_power_9 (OTHER_FAULT)
	694 - matrix_power_12 (Timeout)
	699 - matrix_power_8 (OTHER_FAULT)
	714 - sparse_extra_3 (OTHER_FAULT)
	740 - levenberg_marquardt (OTHER_FAULT)
	764 - cxx11_tensor_io (SEGFAULT)

is that what you expect ?

Note You need to log in before you can comment on or make changes to this bug.