New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Bug 1276 - binder1st and binder2nd warnings
Summary: binder1st and binder2nd warnings
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Core - general (show other bugs)
Version: 3.2
Hardware: All All
: Normal Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
: 1309 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-18 11:29 UTC by Andrea Nicastro
Modified: 2016-09-25 13:00 UTC (History)
4 users (show)



Attachments

Description Andrea Nicastro 2016-08-18 11:29:17 UTC
When compiling using Eigen I get the following warnings

Core/Functors.h:977:28: warning: ‘template<class _Operation> class std::binder1st’ is deprecated [-Wdeprecated-declarations]
 struct functor_traits<std::binder1st<T> >


Core/Functors.h:973:28: warning: ‘template<class _Operation> class std::binder2nd’ is deprecated [-Wdeprecated-declarations]
 struct functor_traits<std::binder2nd<T> >


I temporarily solved including Eigen in the following way:

#pragma GCC diagnostic push
#pragma GCC diagnostic ignored "-Wdeprecated-declarations"
#include <Eigen/Core>
#pragma GCC diagnostic pop
Comment 1 Gael Guennebaud 2016-08-22 12:54:11 UTC
Backported from 3.3:
https://bitbucket.org/eigen/eigen/commits/c885048087ed/
Comment 2 Gael Guennebaud 2016-09-25 13:00:31 UTC
*** Bug 1309 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.