New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Before reporting a bug, please make sure that your Eigen version is up-to-date!
Bug 1198 - levenberg_marquardt test fails (unexpected info code)
Summary: levenberg_marquardt test fails (unexpected info code)
Status: RESOLVED DUPLICATE of bug 1160
Alias: None
Product: Eigen
Classification: Unclassified
Component: Unsupported modules (show other bugs)
Version: 3.3 (current stable)
Hardware: All All
: Normal Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 3.3
  Show dependency treegraph
 
Reported: 2016-04-08 12:50 UTC by Benoit Jacob
Modified: 2016-04-09 08:29 UTC (History)
2 users (show)



Attachments

Description Benoit Jacob 2016-04-08 12:50:09 UTC
levenberg_marquardt fails for me (Ubuntu 14.04, x86-64, gcc 4.8):

Initializing random number generator with seed 1460119722
Repeating each test 10 times

    actual   = 1
    expected = 2

Test testNistMGH10() failed in /usr/local/google/home/benoitjacob/eigen/unsupported/test/levenberg_marquardt.cpp (792)
    test_is_equal(info, LevenbergMarquardtSpace::RelativeErrorTooSmall)
Stack:
  - testNistMGH10()
  - levenberg_marquardt
  - Seed: 1460119722

Aborted (core dumped)
Comment 1 Gael Guennebaud 2016-04-09 08:29:28 UTC

*** This bug has been marked as a duplicate of bug 1160 ***

Note You need to log in before you can comment on or make changes to this bug.