New user self-registration is disabled due to spam. Please email eigen-core-team @ lists.tuxfamily.org if you need an account.
Bug 1175 - SparseMatrix with non-default Index type fails when converting to Matrix (throws bad_alloc because it changes internal index from int to non-default index)
Summary: SparseMatrix with non-default Index type fails when converting to Matrix (thr...
Status: RESOLVED FIXED
Alias: None
Product: Eigen
Classification: Unclassified
Component: Sparse (show other bugs)
Version: 3.2
Hardware: All All
: Normal Unknown
Assignee: Nobody
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-01 11:12 UTC by Dario Villar
Modified: 2016-03-01 14:04 UTC (History)
3 users (show)



Attachments
Test case to reproduce (736 bytes, text/x-c++src)
2016-03-01 11:12 UTC, Dario Villar
no flags Details

Description Dario Villar 2016-03-01 11:12:58 UTC
Created attachment 662 [details]
Test case to reproduce

When trying to convert a SparseMatrix with non-default Index type to Matrix, the dense one changes its internal Index type.

Attached test case to reproduce.
Comment 1 Gael Guennebaud 2016-03-01 14:04:30 UTC
This is already fixed in devel branch because rows/cols always return Index type.

For 3.2:
https://bitbucket.org/eigen/eigen/commits/561623f5f81e/
Summary:     Bug 1175: fix Index type conversion from sparse to dense.

Note You need to log in before you can comment on or make changes to this bug.